We are pleased to inform you that Kustomer Voice is no longer experiencing issues related to the recent event reported by Twilio. While Twilio continues to monitor their update, which was implemented to address call failures, we have confirmed that our services are functioning normally.
We will keep a close eye on the situation alongside our vendor to ensure continued stability. Please check Twilio's status page (https://status.twilio.com/) for ongoing updates. If you have any questions or need further assistance, feel free to contact our support team at support@kustomer.com.
Posted Mar 31, 2025 - 21:43 EDT
Update
Kustomer is aware of an event reported by one of our third party vendors affecting Kustomer Voice. Twilio has implemented an update to address an event that may have caused calls to fail and is continuing to monitor the situation.
Our team continues to monitor the incident, and we are working with the vendor where possible to resolve the issue. Please follow Twilio's status page (https://status.twilio.com/) for more details. Please expect further updates within the next 3 hours, and reach out to Kustomer support at support@kustomer.com if you have additional questions or concerns.
Posted Mar 31, 2025 - 19:01 EDT
Update
Kustomer is aware of an event reported by one of our third party vendors affecting Kustomer Voice. Twilio has implemented an update to address an event that caused calls to potentially fail and are monitoring the situation.
Our team is monitoring the incident, and working with the vendor where possible to resolve the issue. Please follow Twilio's status page (https://status.twilio.com/) for more details. Please expect further updates within the next 3 hours, and reach out to Kustomer support at support@kustomer.com if you have additional questions or concerns.
Posted Mar 31, 2025 - 16:03 EDT
Monitoring
Kustomer is aware of an event reported by one of our third party vendors affecting Kustomer Voice that may cause voice calls to fail within the platform.
Our team is monitoring the incident, and working with the vendor where possible to resolve the issue. Please follow Twilio's status page (https://status.twilio.com/) for more details. Please expect further updates within the next 3 hours, and reach out to Kustomer support at support@kustomer.com if you have additional questions or concerns.
Posted Mar 31, 2025 - 13:33 EDT
This incident affected: Kustomer Voice & Text (Kustomer Voice).