Workflow processing delays
Incident Report for Kustomer
Resolved
Workflow processing rates have been fully restored across the Kustomer platform, and latency has been brought down to normal levels. Workflows can be expected to run on time, and events such as message delivery and queues and routing are behaving as expected. Some clients may still see the occasional older event being processed now but these will be few. Events occurring now are all being processed in real time. We thank you for your patience and understanding as we worked to resolve this incident, and a full report will be shared at status.kustomer.com soon.
Posted 20 days ago. Sep 03, 2019 - 15:06 EDT
Investigating
The Kustomer platform is experiencing increased latency due to an increase in the number of events triggering workflows. Workflows continue to process, but may experience occasional delays. Our engineering team continues to investigate the root cause and is working to lessen the impact to the system. Should you have any additional questions or concerns, please contact support@kustomer.com.
Posted 20 days ago. Sep 03, 2019 - 12:33 EDT
Update
The rate of processing workflow events has been restored to normal levels across the Kustomer platform. We will continue to closely monitor this as the stability of our platform is of the utmost importance to us. Should you have any additional questions or concerns, please contact support@kustomer.com.
Posted 21 days ago. Sep 02, 2019 - 19:50 EDT
Monitoring
At this time most functionality has been restored. We are, however, still monitoring the situation and will share additional information as available. Please contact support@kustomer.com if, for any reason, you continue to experience any issues.
Posted 21 days ago. Sep 02, 2019 - 07:12 EDT
Update
Our engineering team is continuing to investigate the root cause of the workflow delays. Workflows continue to process at a reduced rate while we work to resolve the issue. Please contact support@kustomer.com if you have any additional questions.
Posted 21 days ago. Sep 01, 2019 - 19:59 EDT
Update
Thank you for your continued patience. We have been making progress on resolving the workflow latency, but this issue still remains. We will continue to share progress reports.
Posted 22 days ago. Sep 01, 2019 - 17:14 EDT
Update
We are continuing to work on resolving this issue to restore full workflow processing. We appreciate your patience and will continue to share updates as they are available.
Posted 22 days ago. Sep 01, 2019 - 16:18 EDT
Investigating
Kustomer is currently experiencing a delay in workflow processing. We are working to resolve the issue as quickly as possible. During this time you may experience delays in the processing of events that are affected by your workflows. For support, please contact support@kustomer.com
Posted 22 days ago. Sep 01, 2019 - 15:42 EDT
This incident affected: Workflow.