Degraded Search
Incident Report for Kustomer
Resolved
This incident has been resolved.
Posted Sep 19, 2018 - 14:30 EDT
Identified
We are experiencing delays in search and have identified the root cause; a fix is being worked on currently.
Posted Sep 19, 2018 - 13:01 EDT
This incident affected: Search.