[OUTBOUND WEBHOOKS] Outbound Webhooks API errors in Prod2 and Prod4

Incident Report for Kustomer

Resolved

Kustomer has resolved the event that impacted outbound webhooks in the Prod2 and Prod4 environments. The backported fix has been fully deployed, and webhook delivery is functioning as expected across all affected environments. Our team has verified stability, and no further impact is anticipated.

If you have additional questions or concerns, please reach out to Kustomer support at support@kustomer.com
Posted Dec 09, 2025 - 23:52 EST

Monitoring

Kustomer has implemented a fix for the event impacting outbound webhooks in the Prod2 and Prod4 environments. We are backporting this fix across environments, and our team is monitoring to ensure service stability and continued recovery.

Please expect additional updates within the next 30 minutes, and reach out to Kustomer support at support@kustomer.com if you have additional questions or concerns.
Posted Dec 09, 2025 - 23:22 EST

Update

We are continuing to work on a fix for this issue.
Posted Dec 09, 2025 - 22:55 EST

Identified

Kustomer is aware of an event affecting outbound webhook delivery in our Prod2 environment. Customers may experience failures due to 404 and 503 errors when the platform attempts to send outbound webhooks.

Our team is actively investigating the cause and working toward a resolution.
Please expect additional updates within the next 30 minutes, and reach out to Kustomer Support at support@kustomer.com if you have additional questions or concerns.
Posted Dec 09, 2025 - 22:38 EST
This incident affected: Prod2 (EU) (Web/Email/Form Hooks) and Prod4 (IN) (Web/Email/Form Hooks).