Kustomer has resolved an event affecting tag functionality and tag search, which caused tag usage and search to not work as expected. During the incident, searches involving work items, work sessions, snippets, shortcuts, and the Team Pulse – Skills tab may also have been temporarily impacted.
After careful monitoring, our team has determined that all affected areas are now fully restored. Please reach out to Kustomer Support at support@kustomer.com if you have any additional questions or concerns.
Posted Nov 05, 2025 - 04:19 EST
Update
Kustomer has identified an event currently impacting tag functionality, which may result in tag search and usage not working as expected. Searches involving work items, work sessions, snippets, shortcuts, and the Team Pulse – Skills tab may also be temporarily impacted.
Our Engineering team has identified the cause and is implementing mitigations to restore full functionality. We’ll continue to provide updates every 30 minutes until the issue is fully resolved.
For any additional questions or updates, please don’t hesitate to contact Kustomer Support at support@kustomer.com.
Posted Nov 05, 2025 - 04:12 EST
Identified
Kustomer has identified an event currently impacting tag functionality, which may result in tag search and usage not working as expected. Searches involving work items, work sessions, snippets, shortcuts, and the Team Pulse – Skills tab may also be temporarily impacted.
Our Engineering team has identified the cause and is implementing mitigations to restore full functionality. We’ll continue to provide updates every 30 minutes until the issue is fully resolved.
For any additional questions or updates, please don’t hesitate to contact Kustomer Support at support@kustomer.com.
Posted Nov 05, 2025 - 04:12 EST
Investigating
Kustomer is aware of an event currently impacting tag functionality, which may result in tag search and usage not working as expected. Searches involving work items, work sessions, snippets, shortcuts, and the Team Pulse – Skills tab may also be temporarily impacted.
Our Engineering team is actively investigating the issue to determine the underlying cause and implement a resolution. We’ll provide an update within the next 30 minutes.
We sincerely apologize for the disruption and appreciate your patience and understanding. For any additional questions or updates, please don’t hesitate to contact Kustomer Support at support@kustomer.com.