Gmail sending/receiving errors
Incident Report for Kustomer
Resolved
Google has resolved the incident that caused delays in message sending and receiving, as well as other issues in the Google suite. Kustomer has since redriven all inbound and outbound messages affected during the incident window. If you see any missing messages, please reach out to support@kustomer.com for assistance.
Posted Mar 26, 2020 - 14:21 EDT
Monitoring
At this time, the error rate has dropped significantly and we are observing normal or near normal behavior. Google has also shared the following message, "Gmail service has already been restored for some users, and we expect a resolution for all users within the next 1 hours. Please note this time frame is an estimate and may change."

Kustomer will continue to monitor the situation to ensure that all emails are delivered, and we will share another update here when the incident is fully resolved.
Posted Mar 26, 2020 - 13:06 EDT
Update
We are continuing to monitor this situation closely. Google has since shared additional information regarding the impact of this outage, which can be found at https://www.google.com/appsstatus#hl=en&v=status. Again, any messages that are pending at this time will be automatically sent or delivered upon the restoration of Google's services.
Posted Mar 26, 2020 - 12:54 EDT
Identified
We have identified that the source of this issue is an outage with Google Cloud Platform. We are monitoring the status at https://status.cloud.google.com/. Kustomer's services are all behaving as expecting, and when Gmail’s APIs are restored, Kustomer will automatically ingest any historical messages sent or received during this time, and send any pending messages. We will continue to share information as it becomes available.
Posted Mar 26, 2020 - 12:09 EDT
Investigating
We are currently investigating an issue with sending and receiving emails via the Gmail application. We are looking into all possible causes at this time, and will continue to share updates here as they are available. Please contact support@kustomer.com with any questions.
Posted Mar 26, 2020 - 11:59 EDT
This incident affected: Prod1 (US) (Channel - Email).