[Kustomer Voice] Unable to Dial Outbound Calls - All PRODS

Incident Report for Kustomer

Resolved

Kustomer has resolved an event affecting Kustomer Voice across all PRODs. To resolve this issue, our team has rolled back an update.

After careful monitoring, our team has determined that all affected areas are now fully restored. Please reach out to Kustomer support at support@kustomer.com if you have additional questions or concerns.
Posted Sep 09, 2026 - 15:52 EDT

Monitoring

Kustomer has implemented an update to address an event affecting Kustomer Voice across all PRODs.

Our team is currently monitoring this update to ensure the issue is fully resolved. In order to fully resolve the issue on your end please have all agents refresh their Kustomer Instance.
Posted Sep 09, 2026 - 15:45 EDT

Investigating

Kustomer has identified an event affecting Kustomer Voice across all PRODS that may cause issues when attempting to make outbound calls.

Our team is currently working to implement a resolution. Please expect further updates within the next 30 minutes.
Posted Sep 09, 2026 - 15:25 EDT
This incident affected: Kustomer Voice & Text (Kustomer Voice).