Kustomer application experiencing latency
Incident Report for Kustomer
Resolved
At this time, AWS Cloudfront is reporting full restoration of service. Kustomer is also observing normal response times and error rates, so users in all locations should no longer be experiencing any latency. Please contact support@kustomer.com with any additional questions.
Posted Mar 30, 2020 - 21:39 EDT
Update
While AWS continue to work toward a full recovery, they have noted that error rates have recovered for all locations except Europe. As a result, some Kustomer users in Europe may continue to experience intermittent issues. We will share an update when the issue is fully resolved.
Posted Mar 30, 2020 - 21:21 EDT
Update
Beginning at approximately 7:30pm ET, we began and continue to observe response times consistent with our normal behavior. AWS, as reflected by their status page, continue to work on the cause of the issue within Cloudfront, but we are confident that the impact to users of the Kustomer platform is minimal at this time. We will, however, continue to monitor the situation and remain in touch with AWS until it is fully resolved.
Posted Mar 30, 2020 - 20:12 EDT
Monitoring
We have identified the source of latency noticed by a limited number of users. Amazon Web Services is currently reporting an incident with Cloudfront, which may cause users in certain locations to experience slowness when using the Kustomer platform. More information can be found at https://status.aws.amazon.com. We will continue to monitor the situation and share more information as it becomes available, but the majority of users should be experiencing no issues at this time. Please contact support@kustomer.com with any questions.
Posted Mar 30, 2020 - 19:38 EDT
Investigating
The Kustomer application is currently experiencing latency across the platform. We are investigating the cause of this issue and affected components, and will continue to share information here. Please reach out to support@kustomer.com with any questions.
Posted Mar 30, 2020 - 19:09 EDT
This incident affected: Prod1 (US) (Web Client).