Delays on Inbound Emails
Incident Report for Kustomer
Resolved
Our provider has resolved an issue wherein inbound email processing was delayed on their platform.
Posted 3 months ago. Apr 02, 2019 - 12:38 EDT
Identified
Our provider has identified an issue with delayed inbound email processing on their platform.
Posted 3 months ago. Apr 02, 2019 - 12:29 EDT
This incident affected: Channels (Email).