WhatsApp has confirmed that all services are fully recovered. After careful monitoring, our team has determined that all affected areas are now fully restored. Please reach out to Kustomer support at support@kustomer.com if you have additional questions or concerns.
Posted Jun 12, 2026 - 17:38 EDT
Monitoring
Kustomer is aware of an event reported by one of our third party vendors affecting ALL PRODS that may cause Issues with WhatsApp messages not being delivered to end users.
Our team is monitoring the incident, and working with the vendor where possible to resolve the issue. We are working on redriving previously unsent messages to ensure all messages are sent successfully. Please expect further updates within the next 3 hours, and reach out to Kustomer support at support@kustomer.com if you have additional questions or concerns.
Posted Jun 12, 2026 - 15:29 EDT
Update
Kustomer continues to monitor the ongoing issue on Whatsapp that may cause outbound Whatsapp messages to not be delivered to end users.
Please expect further updates within the next 30 minutes, and reach out to Kustomer Support at support@kustomer.com if you have additional questions or concerns
Posted Jun 12, 2026 - 12:35 EDT
Update
Kustomer continues to monitor the ongoing issue on Whatsapp that may cause outbound Whatsapp messages to not be delivered to end users.
Please expect further updates within the next 30 minutes, and reach out to Kustomer Support at support@kustomer.com if you have additional questions or concerns
Posted Jun 12, 2026 - 11:17 EDT
Identified
Kustomer has identified an ongoing issue with WhatsApp that may cause outbound messages to not be delivered to end users.
Our team is closely monitoring the situation and actively working to assess impact. Clients can refer to https://metastatus.com/whatsapp-business-api for the latest WhatsApp service status.
Please expect further updates within the next 30 minutes, and reach out to Kustomer Support at support@kustomer.com if you have additional questions or concerns.
Posted Jun 12, 2026 - 10:46 EDT
Investigating
Kustomer is aware of an ongoing WhatsApp issue that may cause outbound messages to not be delivered to end users.
While the issue appears to originate with WhatsApp, our team is actively monitoring the situation and working closely to assess the impact on the platform. We will continue to provide updates as more information becomes available.
Please expect an additional update within the next 30 minutes. If you have any questions, please contact Kustomer Support at support@kustomer.com.
Posted Jun 12, 2026 - 10:31 EDT
This incident affected: Third Party (Channel - WhatsApp).