UI Blank Page Outage - 8/27/2019
Incident Report for Kustomer
Postmortem

Blank Screen Outage 8/27/19

Summary
On August 27, 2019, at approximately 4:17 PM EST, the Kustomer team was notified by our internal support team of an app failure causing the app not to load. Users on the affected version of Kustomer experienced the outage from approximately 4:10pm EST to 4:20pm EST. This outage did not affect users on all previous versions of the app, nor were our API services down.

The incident was caused by a dependency issue being released into our production environment. To prevent this type of outage from happening in the future, the Kustomer team will add tests to validate dependency changes across all environments.

Posted 24 days ago. Aug 30, 2019 - 10:07 EDT

Resolved
Blank Screen Outage
8/27/19

Summary
On August 27, 2019, at approximately 4:17 PM EST, the Kustomer team was notified by our internal support team of an app failure causing the app not to load. Users on the affected version of Kustomer experienced the outage from approximately 4:10pm EST to 4:20pm EST. This outage did not affect users on all previous versions of the app, nor were our API services down.

The incident was caused by a dependency issue being released into our production environment. To prevent this type of outage from happening in the future, the Kustomer team will add tests to validate dependency changes across all environments.
Posted 27 days ago. Aug 27, 2019 - 04:15 EDT