Delays in Bulk Processing
Incident Report for Kustomer
Resolved
The incident affecting bulk jobs has been resolved.
Posted 3 months ago. Apr 23, 2019 - 13:08 EDT
Monitoring
We are currently monitoring delays in bulk processing. Bulk requests such as assignment or email affected.
Posted 3 months ago. Apr 23, 2019 - 08:45 EDT
This incident affected: Bulk Jobs.