Twillio Delivery Delays
Incident Report for Kustomer
Resolved
This issue has been resolved by Twilio and deliverability has returned to normal.
Posted Nov 20, 2019 - 15:01 EST
Monitoring
We have been alerted that Twillio is experiencing issues with delivery to U.S. Cellular subscribers. Kustomer users may see deliverability issues as a result of this. Please visit https://status.twilio.com/ for more information. We will monitor this issue as well and post updates here as appropriate.
Posted Nov 20, 2019 - 14:03 EST
This incident affected: Prod1 (US) (Channel - SMS).