PubNub Region-Wide Service Issues in Europe
Incident Report for Kustomer
Postmortem

Summary

A failure in an underlying cloud provider was causing elevated errors and latency in PubNub's European point-of-presence. They routed traffic around the errors while the issues persisted and the issues have now been corrected. We are currently monitoring traffic to ensure there are no other issues.

What Happened

Due to a data center failure of one of PubNub’s cloud infrastructure providers, they experienced higher than usual latencies across all of their services in their Europe point-of-presence from 7:06 am EST to 7:55 am EST. They routed traffic around these issues to minimize latency and impact while the provider rectified its issues. Once the infrastructure was stable, they were able to return traffic to its normal flow.

Impact

While we received alerts on the backend of this issue, there were no discernible issues affecting the Kustomer application.  Clients may have experienced brief issues with chat connectivity during this time but this was not reported to us. 

More information on this issue can be found on PubNub’s site directly here.

Posted Jan 10, 2022 - 13:18 EST

Resolved
The incident has not resurfaced since 12:56 UTC. PubNub has resolved the incident and will be following up with a post-mortem soon. You can keep updated at https://status.pubnub.com/incidents/pnn3b09sh4h4
Posted Jul 13, 2021 - 10:19 EDT
Monitoring
A failure in an underlying cloud provider was causing elevated errors and latency in PubNub's European point-of-presence. They routed traffic around the errors while the issues persisted and the issues have now been corrected. We are currently monitoring traffic to ensure there are no other issues.
Posted Jul 13, 2021 - 09:37 EDT
This incident affected: Third Party (PubNub).