Google Services
Incident Report for Kustomer
Resolved
This incident has been resolved by Google, and we are currently retrying any queued messages.
Posted about 2 months ago. Jun 02, 2019 - 19:39 EDT
Monitoring
We are currently monitoring issues with Google Services impacting our ability to send and receive messages via Gmail. You may observe delays in sending and receiving until the issues are resolved by Google. https://www.google.com/appsstatus#hl=en&v=status
Posted about 2 months ago. Jun 02, 2019 - 16:27 EDT
This incident affected: Channels (Email).