Degraded Performance
Incident Report for Kustomer
Resolved
This incident has been resolved.
Posted 8 months ago. Oct 18, 2018 - 15:35 EDT
Monitoring
A fix has been implemented and we are monitoring actively.
Posted 8 months ago. Oct 18, 2018 - 13:48 EDT
Identified
We have identified an issue with the performance of the Kustomer platform for some users and we are currently investigating.
Posted 8 months ago. Oct 18, 2018 - 13:26 EDT
This incident affected: Web Client.