Degraded Search
Incident Report for Kustomer
Resolved
This incident has been resolved.
Posted 11 months ago. Sep 18, 2018 - 14:04 EDT
Investigating
We are currently experiencing search delays, impacting search update times and autopilot
Posted 11 months ago. Sep 18, 2018 - 14:01 EDT
This incident affected: Search.