Reported Third Party Event - Billing system provider is experiencing degraded performance
Incident Report for Kustomer
Resolved
The issue from our billing system provider Zuora has been resolved.

Further information is available on https://trust.zuora.com/

Please reach out to Support at support@kustomer.com if you have additional questions or concerns.
Posted Aug 05, 2022 - 03:29 EDT
Update
Our billing system provider is experiencing degraded performance.

This can prevent clients from updating their seat count, from converting trials, and from seeing manual billing changes in reflected in their orgs.

For more information,
Please reach out to our Support team with any additional questions. You can reach us by going to https://help.kustomer.com/ and clicking "Contact Support" at the top of the page.
Posted Aug 04, 2022 - 23:11 EDT
Monitoring
Our billing system provider is experiencing degraded performance.

This can prevent clients from updating their seat count, from converting trials, and from seeing manual billing changes in reflected in their orgs.

For more information,

Please reach out to our Support team with any additional questions. You can reach us by going to https://help.kustomer.com/ and clicking "Contact Support" at the top of the page.
Posted Aug 04, 2022 - 16:27 EDT
Identified
Zuora is experiencing degraded performance.

This can prevent clients from updating their seat count, from converting trials, and from seeing manual billing changes in Zuora reflected in their orgs.

For more information, please refer to
https://trust.zuora.com/

Please reach out to our Support team with any additional questions. You can reach us by going to https://help.kustomer.com/ and clicking "Contact Support" at the top of the page.
Posted Aug 04, 2022 - 16:15 EDT
This incident affected: Prod1 (US) (API) and Prod2 (EU) (API).