Delays in PostMark Webhook Deliverability
Incident Report for Kustomer
Postmortem

Summary

On 11/24/2021 at around 3:11 pm EST we received word from Postmark that they were experiencing delays with their webhooks, delivery events, bounce processing, and statistics due to an issue with AWS. We received another notice that this was resolved by 3:30 pm EST.

What Happened

Delays due to an AWS incident (https://status.aws.amazon.com/) were causing delays with webhooks, delivery events, bounce processing, and statistics but outbound sending and inbound processing were not impacted. By 3:30pm EST all webhooks, bounce processing, and activity events have been processed.

Impact

Users may have experienced delays with their webhooks, delivery events, bounce processing, and statistics due to an issue with AWS. Sending and inbound processing was not impacted during this time.

Postmark’s postmortem on this is available here.

Posted Jan 10, 2022 - 11:36 EST

Resolved
This incident has been resolved.
Posted Nov 24, 2021 - 16:17 EST
Investigating
Postmark has changed all systems back to fully operational. Please reach out to Support with any questions you may have.
Posted Nov 24, 2021 - 15:11 EST
This incident affected: Prod2 (EU) (Web/Email/Form Hooks).