Bulk Email not setting “from” address. APIs still functional, only Bulk UI affected
Incident Report for Kustomer
Resolved
This incident has been resolved.
Posted Apr 02, 2019 - 14:04 EDT
Identified
We have identified an issue with the Bulk UI which is affecting setting the "from" address for bulk emails. APIs are still functional, and we are actively working on the issue.
Posted Apr 02, 2019 - 13:17 EDT
This incident affected: Web Client.