App Loading Slowly
Incident Report for Kustomer
Resolved
Performance has returned to normal and we are continuing to monitor the system. We have identified the root cause and are working to prevent incidents like this in the future. If you have any questions, please don't hesitate to reach out to support@kustomer.com
Posted over 1 year ago. Dec 20, 2017 - 12:39 EST
Identified
We have identified the issue and are working on a fix. Our team will continue to provide updates as they are available.
Posted over 1 year ago. Dec 20, 2017 - 11:51 EST
Investigating
We are investigating issues that are causing the app to load slowly. Our team will provide updates as they are available.
Posted over 1 year ago. Dec 20, 2017 - 11:18 EST